Информатика (Вариант 6)


  • 1
  • 2
  • 3
  • 4
  • 5
  • 6

Вопрос 8

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования). 

БейсикПаскаль
DIM N, S AS INTEGER 
 N = 10 
 S = 0 
 WHILE S <= 249 
S = S + 24 
N = N + 3 
 WEND 
 PRINT N
var n, s: integer; 
 begin 
    n := 10; 
    s := 0; 
    while s <= 249 do 
    begin 
        s := s + 24; 
        n := n + 3 
    end;  
    write(n) 
 end.

 

Си++Алгоритмический язык
#include <iostream>
using namespacestd; 
 int main() 
 { 
    int n, s; 
    n = 10; 
    s = 0; 
    while (s <= 249) 
    { 
        s = s + 24; 
        n = n + 3; 
    } 
    cout « n « endl; 
 }
алг 
 нач  
 цел n, s 
 n := 10 
 s := 0 
 нц пока s <= 249 
    s := s + 24 
    n := n + 3 
 кц 
 вывод n 
 кон
Python

n = 10

s = 0

while s <= 249:

    s += 24

    n += 3

print(n)