Информатика (Вариант 4)


  • 1
  • 2
  • 3
  • 4
  • 5
  • 6

Вопрос 20

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 8, а потом 5. 

БейсикПаскаль
DIM X, A, B, C AS INTEGER 
 INPUT X 
 A = 0: B = 0 
 WHILE X > 0 
    C = X MOD 10 
    A = A + C 
    IF C > B THEN B = C 
    X = X  10 
 WEND 
 PRINT A 
 PRINT B
var x, a, b, c: integer; 
begin 
    readln(x); 
    a := 0; b := 0; 
    while x>0 do 
        begin 
            c := x mod 10; 
            a := a+c; 
            if c>b then b := c; 
            x := x div 10; 
        end; 
    writeln(a); write(b); 
end.
Си++Алгоритмический
#include <iostream> 
using namespacestd;
int main() 
{ 
    int x, a, b, c; 
    cin >> x; 
    a = 0; b = 0; 
    while (x>0) { 
        c = x%10; 
        a = a+c; 
        if (c>b) 
            b = c; 
        x = x/10; 
    } 
    cout << a << endl << bendl; 
}
алг 
нач 
цел x, a, b, c 
ввод x 
a := 0; b := 0 
нц пока x>0 
    c := mod(x,10) 
    a := a+c 
        если c>b 
    то b := c 
    все 
    x := div(x,10) 
кц 
вывод a, нс, b 
 кон
Python
x = int(input())
a = 0
b = 0
while x > 0:
    c = x % 10
    a += c
    if c > b:
        b = c
    x //= 10
print(a)
print(b)