Информатика (Вариант 4)


  • 1
  • 2
  • 3
  • 4
  • 5
  • 6

Вопрос 19

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 8, 10, 7, 4, 6, 12, 15 (т.е. A[1] = 2, A[2] = 3, …, A[10] = 15).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).  

БейсикPython
n = 10
s = 0
 FOR i = 2 TO n
    IF A(i-1) < A(i) THEN
        A(i) = A(i) + A(i-1)
        s = s + A(i)
    END IF
 NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

 

 

ПаскальАлгоритмический язык
n := 10;
s := 0;
for i:=2 to n do begin
    if A[i-1] < A[i] then begin
        A[i] := A[i] + A[i-1];
        s := s + A[i]
    end
end;
n := 10
s := 0
нц для i от 2 до n
    если A[i-1] < A[i]
        то
            A[i] := A[i] + A[i-1]
            s := s + A[i]
    все
кц
Си++
n = 10;
s = 0;
for (i = 2; i <= n; ++i) {
    if (A[i-1] < A[i]) {
        A[i] = A[i] + A[i-1];
        s = s + A[i];
    }
}