Информатика (Вариант 1)


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
  • 1
  • 2
  • 3

Вопрос 6

Ниже приведена программа, записанная на пяти языках программирования.

  

БейсикPython
DIM s, t AS INTEGER
 INPUT s
 INPUT t
 IF s > 9 OR t > 9 THEN
    PRINT ‘ДА’
 ELSE
    PRINT ‘НЕТ’
 ENDIF

s = int(input())

t = int(input())

if s > 9 or t > 9:

    print("ДА")

else:

    print("НЕТ")

 

 

ПаскальАлгоритмический язык
var s, t: integer;
begin
    readln(s);
    readln(t);
    if (s > 9) or (t > 9)
        then writeln("ДА")
        else writeln("НЕТ")
end.
алг
нач
цел s, t
ввод s
ввод t
если s > 9 или t > 9
    то вывод "ДА"
    иначе вывод "НЕТ"
все
кон
С++
#include <iostream>
using namespacestd;
int main() {
    int s, t;
    cin >> s;
    cin >> t;
    if (s > 9 || t > 9)
        cout << "ДА";
    else
        cout << "НЕТ";
return 0;
}

 

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 

(9, 9); (9, 10); (8, 5); (11, 6); (–11, 10); (–5, 9); (–10, 10); (4, 5); (8, 6).

 

Сколько было запусков, при которых программа напечатала «НЕТ»?