Информатика (Вариант 9)


  • 1
  • 2
  • 3
  • 4
  • 5
  • 6

Вопрос 8

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования): 

БейсикПаскаль
DIM N, S AS INTEGER
 N = 0
 S = 512
 WHILE S  >= 0
    S = S - 20
    N = N + 1
 WEND
 PRINT  N
var n, s: integer;
begin
    n := 0;
    s := 512;
    while s >= 0 do
    begin
        s := s - 20;
    n := n + 1
    end;
    write(n)
end.

 

Си++Алгоритмический язык
#include <iostream> 
using namespacestd;
int main()
{
    int n, s;
    n = 0;
    s = 512;
    while (s >= 0)
    {
        s = s - 20;
        n = n + 1;
    }
    cout « n « endl;
}

 

алг
нач
    цел n, s
    n := 0
    s := 512
    нц пока s >= 0
        s := s - 20
        n := n + 1
    кц
    вывод n
кон
Python

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)