Информатика (Вариант 9)


  • 1
  • 2
  • 3
  • 4
  • 5
  • 6

Вопрос 19

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6; 4; 5; 4; 3; 3; 9; 8; 6; 2 соответственно, т.е. A[0] = 6; A[1] = 4 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.  

БейсикPython
c = 0
 FOR i = 1 TO 9
    IF A(i - 1) < A(i) THEN
        t = A(i)
        A(i) = A(i - 1)
        A(i - 1) = t
        c = c + 1
    ENDIF
 NEXT i

 

c = 0

for i in range(1, 10):

    if A[i - 1] < A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

        c = c + 1

 

 

Алгоритмический языкПаскаль
c := 0
нц для i от 1 до 9
    если A[i - 1] < A[i] то
        t := A[i]
        A[i] := A[i - 1]
        A[i - 1] := t
        c := c + 1
    все
кц

 

c := 0;
for i := 1 to 9 do
    if A[i - 1] < A[i] then
    begin
        t := A[i];
        A[i] := A[i - 1];
        A[i - 1] := t;
        c := c + 1;
    end;

 

Си++
c = 0;
for (i = 1; i <= 9; i++)
    if (A[i - 1] < A[i])
    {
        t = A[i];
        A[i] = A[i - 1];
        A[i - 1] = t;
        c++;
    }