Информатика (Программа с условным оператором)



Вопрос 6

Ниже приведена программа, записанная на пяти языках программирования. 

БейсикPython
DIM s, t AS INTEGER
 INPUT s
 INPUT t
 IF s > 8 AND t > 8 THEN
    PRINT ‘ДА’
 ELSE
    PRINT ‘НЕТ’
 ENDIF

s = int(input())

t = int(input())

if s > 8 and t > 8:

    print("ДА")

else:

    print("НЕТ")

 

 

ПаскальАлгоритмический язык
var s, t: integer;
begin
    readln(s);
    readln(t);
    if (s > 8) and (t > 8)
        then writeln("ДА")
        else writeln("НЕТ")
end.
алг
нач
цел s, t
ввод s
ввод t
если s > 8 и t > 8
    то вывод "ДА"
    иначе вывод "НЕТ"
все
кон
С++
#include <iostream>
using namespacestd;
int main() {
    int s, t;
    cin >> s;
    cin >> t;
    if (s > 8 && t > 8)
        cout << "ДА";
    else
        cout << "НЕТ";
return 0;
}

 

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 

(9, 10); (11, 5); (–2, 8); (9, 9); (2, 8); (–1, 3); (–4, 5); (10, 9); (4, –3).

 

Сколько было запусков, при которых программа напечатала «НЕТ»?