Информатика (Простейший циклический алгоритм, записанный на алгоритмическом языке)



Вопрос 9

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.  

 

БейсикPython
DIM k, s AS INTEGER 
s = 0
 FOR k = 8 TO 12 
    s = s + 12 
 NEXT k 
 PRINT s

s = 0

for k in range(8,13):

    s = s + 12

print (s)

 

 

ПаскальАлгоритмический язык
var s,k: integer; 
begin 
    s := 0;
    for k := 8 to 12 do
        s := s + 12; 
    writeln(s); 
end.
алг
нач 
   цел s, k 
   s := 0
   нц для k от 8 до 12
      s := s + 12
   кц
   вывод s 
кон
С++
#include <iostream>
using namespacestd;
int main() {
     int s = 0;
     for (int k = 8; k <= 12; k++) 
          s += 12;
     cout << s;
     return 0;
}