Информатика (Анализ программы с циклами и условными операторами)



Вопрос 20

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 15. 

БейсикPython
DIM X, L, M AS INTEGER
 INPUT X
 L = X - 30
 M = X + 30
 WHILE L <> M
   IF L > M THEN
     L = L – M
   ELSE
     M = M – L
 END IF
 WEND
 PRINT M

x = int(input())

L = x-30

M = x+30

while L != M:

  if L > M:

    L = L - M

  else:

    M = M - L

print(M)

 

 

ПаскальАлгоритмический язык
var x, L, M: integer;
begin
  readln(x);
  L := x-30;
  M := x+30;
  while L <> M do
    if L > M then
      L := L - M
    else
      M := M – L;
  writeln(M);
end.
алг
нач
  цел x, L, M
  ввод x
  L := x-30
  M := x+30
  нц пока L <> M
    если L > M
      то
      L := L – M
      иначе
      M := M – L
    все
  кц
  вывод M
кон
Си++
#include <iostream>
using namespacestd;
int main()
{
  int x, L, M;
  cin >> x;
  L = x-30;
  M = x+30;
  while (L != M){
    if(L > M)
      L = L - M;
    else
      M = M - L;
  }
  cout « M « endl;
  return 0;
}