Информатика (Обработка массивов и матриц)



Вопрос 19

Дан фрагмент программы, обрабатывающей двухмерный массив A[1..5,1..4]: 

БейсикPython
k = 4
 FOR m = 1 TO 4 
    k = k + 1
    FOR n = 1 TO 5
        k = m - k
        A(n,m) = n*n+m*m-2*k
    NEXT n
 NEXT m
 

k = 4

for m in range(1, 5):

   k += 1

   for n in range(1, 6):

      k=m-k

      A[n][m]=n*n+m*m-2*k

 

 

ПаскальАлгоритмический язык
k:=4;
for m:=1 to 4 do begin
   k:=k+1;
   for n:=1 to 5 do begin
       k:=m-k;
       A[n,m]:=n*n+m*m-2*k;
    end;
end;
k:=4
нц для m от 1 до 4
    k:=k+1
    нц для n от 1 до 5
        k:=m-k
        A[n,m]:=n*n+m*m-2*k
    кц
кц
 
Си++
k = 4;
for (m = 1; m <= 4; m++) {
    k = k + 1;
    for (n = 1; n <= 5; n++) {
        k=m-k;
        A[n][m]=n*n+m*m-2*k;
    }
}

 

 

Чему будет равно значение A[3,1]?