Информатика (Анализ программ)



Вопрос 8

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования. 

БейсикPython
DIM S, N AS INTEGER
 S = 0
 N = 0
 WHILE S <= 65
S = S + 5
N = N + 3
 WEND
 PRINT N

s = 0

n = 0

while s <= 65:

    s = s + 5

    n = n + 3

print(n)

 

 

ПаскальАлгоритмический язык
var s, n: integer;
begin
    s := 0;
    n := 0;
    while s <= 65 do
    begin
        s := s + 5;
        n := n + 3
    end;
    writeln(n)
end.

 

алг
нач
цел n, s
s := 0
n := 0
нц пока s <= 65
    s := s + 5
    n := n + 3
кц
вывод n
кон
Си++
#include <iostream>
using namespacestd;
int main()
{
    int s = 0, n = 0;
    while (s <= 65)
    {
        s = s + 5;
        n = n + 3;
    }
    cout << n << endl; 
    return 0;
}